UnratednpmAmendedPublished
hull.js Code Injection Vulnerability
GHSA-q849-wxrc-vqrp
- Affected
- npm hull.js >= 0.2.2, < 1.0.10
- Fixed in
- 1.0.10· Vendor fix available
- Issue
- Versions of the library from 0.2.2 to 1.0.9 are vulnerable to the arbitrary code execution due to unsafe usage of new Function(...) in the module that handles points format. Applications passing the 3rd parameter to the hull function without sanitising may be impacted. The vulnerability has been fixed in version 1.0.10, please update the library. Check project homepage on GitHub to see how to fetch the latest version: https://github.com/andriiheonia/hull?tab=readme-ov-file#npm-package
Recommended action: Upgrade to 1.0.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.