Critical, CVSS 9.8npmAmendedPublished
Potential Command Injection in hubot-scripts
CVE-2013-7378 · GHSA-hwch-749c-rv63
- Affected
- npm hubot-scripts <= 2.4.3
- Fixed in
- 2.4.5· Vendor fix available
- Issue
- Versions 2.4.3 and earlier of hubot-scripts are vulnerable to a command injection vulnerablity in the hubot-scripts/package/src/scripts/email.coffee module. Mitigating Factors The email script is not enabled by default, it has to be manually added to hubot's list of loaded scripts. Recommendation Update hubot-scripts to version 2.4.4 or later.
Recommended action: Upgrade to 2.4.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.