High, CVSS 7.5npmAmendedPublished
Directory Traversal in hostr
CVE-2017-16029 · GHSA-xqqr-p362-6rmc
- Affected
- npm hostr <= 2.3.5
- Fixed in
- 2.3.6· Vendor fix available
- Issue
- Affected versions of hostr are vulnerable to directory traversal which allows attackers to read files outside the current directory by sending ../ in the url path for GET requests. Recommendation Upgrade to version 2.3.6 or later.
Recommended action: Upgrade to 2.3.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.