Medium, CVSS 6.5npmAmendedPublished
Configuration Override in helmet-csp
GHSA-c3m8-x3cg-qm2c
- Affected
- npm helmet-csp >= 1.2.2, < 2.9.1
- Fixed in
- 2.9.1· Vendor fix available
- Issue
- Versions of helmet-csp before to 2.9.1 are vulnerable to a Configuration Override affecting the application's Content Security Policy (CSP). The package's browser sniffing for Firefox deletes the default-src CSP policy, which is the fallback policy. This allows an attacker to remove an application's default CSP, possibly rendering the application vulnerable to Cross-Site Scripting. Recommendation Upgrade to version 2.9.1 or later. Setting the browserSniff configuration to false in vulnerable versions also mitigates the issue.
Recommended action: Upgrade to 2.9.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.