Critical, CVSS 9.8npmAmendedPublished
Authentication Bypass in hapi-auth-jwt2
CVE-2016-10525 · GHSA-mg8r-9g6j-hwv9
- Affected
- npm hapi-auth-jwt2 >= 5.1.1, <= 5.1.1
- Fixed in
- 5.1.2· Vendor fix available
- Issue
- Versions of hapi-auth-jwt2 prior to version 5.1.2 are affected by a complete authentication bypass vulnerability when in the try authentication mode. Recommendation Update to version 5.1.2 or later.
Recommended action: Upgrade to 5.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.