Skip to content

← Public intelligence

npm package

google-closure-library

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5npmAmendedPublished

    Improper Input Validation in Google Closure Library

    CVE-2020-8910 · GHSA-vh5w-fg69-rc8m

    Affected
    • npm google-closure-library <= 20200224.0.0
    Fixed in
    20200315.0.0· Vendor fix available
    Issue
    A URL parsing issue in goog.uri of the Google Closure Library versions up to and including v20200224 allows an attacker to send malicious URLs to be parsed by the library and return the wrong authority. Mitigation -- update your library to version v20200315.

    Recommended action: Upgrade to 20200315.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Cross-Site Scripting in google-closure-library

    GHSA-r9q4-w3fm-wrm2

    Affected
    • npm google-closure-library < 20190301.0.0
    Fixed in
    20190301.0.0· Vendor fix available
    Issue
    Versions of google-closure-library prior to 20190301.0.0 are vulnerable to Cross-Site Scripting. The safedomtreeprocessor.processToString() function improperly processed empty elements, which could allow attackers to execute arbitrary JavaScript through Mutation Cross-Site Scripting. Recommendation Upgrade to version 20190301.0.0 or later.

    Recommended action: Upgrade to 20190301.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →