Skip to content

← Public intelligence

npm package

glob-parent

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    glob-parent 6.0.0 vulnerable to Regular Expression Denial of Service

    CVE-2021-35065 · GHSA-cj88-88mr-972w

    Affected
    • npm glob-parent >= 6.0.0, <= 6.0.0
    Fixed in
    6.0.1· Vendor fix available
    Issue
    glob-parent 6.0.0 is vulnerable to Regular Expression Denial of Service (ReDoS). This issue is fixed in version 6.0.1. This vulnerability is separate from GHSA-ww39-953v-wcq6.

    Recommended action: Upgrade to 6.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    glob-parent vulnerable to Regular Expression Denial of Service in enclosure regex

    CVE-2020-28469 · GHSA-ww39-953v-wcq6

    Affected
    • npm glob-parent >= 4.0.0, < 5.1.2
    Fixed in
    5.1.2· Vendor fix available
    Issue
    This affects the package glob-parent before 5.1.2. The enclosure regex used to check for strings ending in enclosure containing path separator.

    Recommended action: Upgrade to 5.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →