Skip to content

← Public intelligence

npm package

glance

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5npmAmendedPublished

    Path traversal vulnerability in glance

    CVE-2022-25937 · GHSA-3hjh-5hgx-f5wh

    Affected
    • npm glance < 3.0.9
    Fixed in
    3.0.9· Vendor fix available
    Issue
    Versions of the package glance before 3.0.9 are vulnerable to Directory Traversal that allows users to read files outside the public root directory. This is related to but distinct from the vulnerability reported in CVE-2018-3715.

    Recommended action: Upgrade to 3.0.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Unauthorized File Access in glance

    GHSA-vw7g-jq9m-3q9v

    Affected
    • npm glance < 3.0.7
    Fixed in
    3.0.7· Vendor fix available
    Issue
    Versions of glance prior to 3.0.7 are vulnerable to Unauthorized File Access. The package provides a --nodot option meant to hide files and directories with names that begin with a ., such as .git but fails to hide files inside a folder that begins with .. Recommendation Upgrade to version 3.0.7 or later.

    Recommended action: Upgrade to 3.0.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  3. Medium, CVSS 6.1npmAmendedPublished

    Cross-Site Scripting in glance

    CVE-2018-3748 · GHSA-7375-vjr2-3g7w

    Affected
    • npm glance < 3.0.8
    Fixed in
    3.0.8· Vendor fix available
    Issue
    Versions of glance before 3.0.8 are vulnerable to Stored Cross-Site Scripting (XSS). This is only exploitable if the attacker is able to control the name of a file that is served by the glance package.

    Recommended action: Upgrade to 3.0.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.5npmAmendedPublished

    Path Traversal in glance

    CVE-2018-3715 · GHSA-2x4q-6jfv-8h9h

    Affected
    • npm glance < 3.0.4
    Fixed in
    3.0.4· Vendor fix available
    Issue
    Versions of glance before 3.0.4 are vulnerable to a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path. Recommendation Update to version 3.0.4 or later.

    Recommended action: Upgrade to 3.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →