High, CVSS 8.8npmAmendedPublished
Command injection in git-parse
CVE-2021-26543 · GHSA-m744-2jj8-vpfv
- Affected
- npm git-parse < 1.0.5
- Fixed in
- 1.0.5· Vendor fix available
- Issue
- The "gitDiff" function in Wayfair git-parse <=1.0.4 has a command injection vulnerability. Clients of the git-parse library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability.
Recommended action: Upgrade to 1.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.