High, CVSS 7.5npmAmendedPublished
Denial of Service in get-ip-range
CVE-2021-27191 · GHSA-6q4w-3wp4-q5wf
- Affected
- npm get-ip-range < 4.0.0
- Fixed in
- 4.0.0· Vendor fix available
- Issue
- The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion. Update get-ip-range dependency to 4.0.0 or above.
Recommended action: Upgrade to 4.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.