Critical, CVSS 9.8npmAmendedPublished
OS Command Injection in GenieACS
CVE-2021-46704 · GHSA-2877-693q-pj33
- Affected
- npm genieacs < 1.2.8
- Fixed in
- 1.2.8· Vendor fix available
- Issue
- In GenieACS 1.2.x before 1.2.8, the UI interface API is vulnerable to unauthenticated OS command injection via the ping host argument (lib/ui/api.ts and lib/ping.ts). The vulnerability arises from insufficient input validation combined with a missing authorization check.
Recommended action: Upgrade to 1.2.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.