Medium, CVSS 6.1npmAmendedPublished
generator-hottowel Cross-site Scripting vulnerability
CVE-2016-15025 · GHSA-f8hv-rx9p-f9r4
- Affected
- npm generator-hottowel < 0.5.0
- Fixed in
- 0.5.0· Vendor fix available
- Issue
- A vulnerability, which was classified as problematic, was found in generator-hottowel 0.0.11. Affected is an unknown function of the file app/templates/src/server/app.js of the component 404 Error Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. The name of the patch is c17092fd4103143a9ddab93c8983ace8bf174396. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-221484.
Recommended action: Upgrade to 0.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.