Critical, CVSS 9.8npmAmendedPublished
Code injection in fsevents
CVE-2023-45311 · GHSA-8r6j-v8pm-fqw3
- Affected
- npm fsevents <= 1.2.10
- Fixed in
- 1.2.11· Vendor fix available
- Issue
- fsevents before 1.2.11 depends on the https://fsevents-binaries.s3-us-west-2.amazonaws.com URL, which might allow an adversary to execute arbitrary code if any JavaScript project (that depends on fsevents) distributes code that was obtained from that URL at a time when it was controlled by an adversary.
Recommended action: Upgrade to 1.2.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.