Skip to content

← Public intelligence

npm package

forms

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    Regular expression denial of service in forms

    CVE-2021-23388 · GHSA-c56f-grv3-gpfr

    Affected
    • npm forms < 1.3.2
    Fixed in
    1.3.2· Vendor fix available
    Issue
    The package forms before 1.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via email validation.

    Recommended action: Upgrade to 1.3.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1npmAmendedPublished

    Cross-Site Scripting in forms

    CVE-2017-16015 · GHSA-vwjj-2852-3765

    Affected
    • npm forms < 1.3.0
    Fixed in
    1.3.0· Vendor fix available
    Issue
    Affected versions of forms do not properly escape HTML in generated forms, which may result in cross-site scripting. Recommendation Update to version 1.3.0 or later.

    Recommended action: Upgrade to 1.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →