Skip to content

← Public intelligence

npm package

feathers-sequelize

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8npmAmendedPublished

    feathers-sequelize vulnerable to SQL injection due to improper parameter filtering

    CVE-2022-29822 · GHSA-5hq7-j5wq-p227

    Affected
    • npm feathers-sequelize >= 6.0.0, < 6.3.4
    Fixed in
    6.3.4· Vendor fix available
    Issue
    feathers-sequelize is vulnerable to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection.

    Recommended action: Upgrade to 6.3.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Feather-Sequelize cleanQuery method vulnerable to Prototype Pollution

    CVE-2022-29823 · GHSA-p5m3-27vh-52j4

    Affected
    • npm feathers-sequelize >= 6.0.0, < 6.3.3
    Fixed in
    6.3.3· Vendor fix available
    Issue
    Feather-Sequelize cleanQuery method uses insecure recursive logic to filter unsupported keys from the query object. This results in a Remote Code Execution (RCE) with privileges of application.

    Recommended action: Upgrade to 6.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.8npmAmendedPublished

    feathers-sequelize contains improper input validation leading to SQL injection

    CVE-2022-2422 · GHSA-qpv8-4pjq-qqh7

    Affected
    • npm feathers-sequelize >= 6.0.0, < 6.3.4
    Fixed in
    6.3.4· Vendor fix available
    Issue
    Due to improper input validation in the Feathers js library, it is possible to perform a SQL injection attack on the back-end database, in case the feathers-sequelize package is used.

    Recommended action: Upgrade to 6.3.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →