High, CVSS 7.7npmAmendedPublished
robinweser fast-loops vulnerable to prototype pollution
CVE-2024-39008 · GHSA-3q56-9cc2-46j4
- Affected
- npm fast-loops < 1.1.4
- Fixed in
- 1.1.4· Vendor fix available
- Issue
- robinweser fast-loops v1.1.3 was discovered to contain a prototype pollution via the function objectMergeDeep. This vulnerability allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via injecting arbitrary properties.
Recommended action: Upgrade to 1.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.