Skip to content

← Public intelligence

npm package

eta

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.6npmAmendedPublished

    XSS Attack with Express API

    CVE-2023-23630 · GHSA-xrh7-m5pp-39r6

    Affected
    • npm eta < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    Impact XSS attack - anyone using the Express API is impacted Patches The problem has been resolved. Users should upgrade to version 2.0.0. Workarounds Don't pass user supplied data directly to res.renderFile. References Are there any links users can visit to find out more? See https://github.com/eta-dev/eta/releases/tag/v2.0.0

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.8npmAmendedPublished

    Eta vulnerable to Code Injection via templates rendered with user-defined data

    CVE-2022-25967 · GHSA-mf6x-hrgr-658f

    Affected
    • npm eta < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    Versions of the package eta before 2.0.0 are vulnerable to Remote Code Execution (RCE) by overwriting template engine configuration variables with view options received from The Express render API. Note: This is exploitable only for users who are rendering templates with user-defined data.

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →