Critical, CVSS 9.8npmAmendedPublished
Arbitrary Code Execution in eslint-utils
CVE-2019-15657 · GHSA-3gx7-xhv7-5mx3
- Affected
- npm eslint-utils >= 1.2.0, < 1.4.1
- Fixed in
- 1.4.1· Vendor fix available
- Issue
- Versions of eslint-utils =1.2.0 or <1.4.1 are vulnerable to Arbitrary Code Execution. The getStaticValue does not properly sanitize user input allowing attackers to supply malicious input that executes arbitrary code during the linting process. The getStringIfConstant and getPropertyName functions are not affected. Recommendation Upgrade to version 1.4.1 or later.
Recommended action: Upgrade to 1.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.