Medium, CVSS 5.5npmAmendedPublished
dom-iterator code execution vulnerability
CVE-2024-21541 · GHSA-jrvm-mcxc-mf6m
- Affected
- npm dom-iterator <= 1.0.0
- Fixed in
- 1.0.1· Vendor fix available
- Issue
- Versions of the package dom-iterator before 1.0.1 are vulnerable to Arbitrary Code Execution due to use of the Function constructor without complete input sanitization. Function generates a new function body and thus care must be given to ensure that the inputs to Function are not attacker-controlled. The risks involved are similar to that of allowing attacker-controlled input to reach eval.
Recommended action: Upgrade to 1.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.