Skip to content

← Public intelligence

npm package

dojo

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4npmPublished

    Cross-Site Scripting in dojo

    CVE-2015-5654 · GHSA-p82g-2xpp-m5r3

    Affected
    • npm dojo < 1.9.1
    Fixed in
    1.9.1· Vendor fix available
    Issue
    Versions of `dojo` prior to 1.2.0 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize HTML code in user-controlled input, allowing attackers to execute arbitrary JavaScript in the victim's browser. Recommendation Upgrade to version 1.2.0 or later.

    Recommended action: Upgrade to 1.9.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  2. UnratednpmAmendedPublished

    Cross-Site Scripting in dojo

    CVE-2008-6681 · GHSA-39cx-xcwj-3rc4

    Affected
    • npm dojo < 1.1.0
    Fixed in
    1.1.0· Vendor fix available
    Issue
    Affected versions of dojo are susceptible to a cross-site scripting vulnerability in the dijit.Editor and textarea components, which execute their contents as Javascript, even when sanitized. Recommendation Update to version 1.1.0 or later.

    Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.7npmAmendedPublished

    Prototype pollution in dojo

    CVE-2020-5258 · GHSA-jxfh-8wgv-vfr2

    Affected
    • npm dojo < 1.11.10; >= 1.12.0, < 1.12.8; >= 1.13.0, < 1.13.7; >= 1.14.0, < 1.14.6; >= 1.15.0, < 1.15.3; >= 1.16.0, < 1.16.2
    Fixed in
    1.11.101.14.61.16.21.12.81.13.71.15.3· Vendor fix available
    Issue
    In affected versions of dojo (NPM package), the deepCopy method is vulnerable to Prototype Pollution. Prototype Pollution refers to the ability to inject properties into existing JavaScript language construct prototypes, such as objects. An attacker manipulates these attributes to overwrite, or pollute, a JavaScript application object prototype of the base object by injecting other values. This has been patched in versions 1.12.8, 1.13.7, 1.14.6, 1.15.3 and 1.16.2

    Recommended action: Upgrade to 1.16.2, 1.15.3, 1.14.6 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. UnratednpmAmendedPublished

    Cross-Site Scripting in dojo

    CVE-2010-2273 · GHSA-536q-8gxx-m782

    Affected
    • npm dojo >= 1.13.0, <= 1.13.0; >= 1.12.0, < 1.12.4; >= 1.11.0, < 1.11.6; >= 1.10.0, < 1.10.10
    Fixed in
    1.12.41.11.61.10.101.13.1· Vendor fix available
    Issue
    Versions of dojo prior to 1.4.2 are vulnerable to DOM-based Cross-Site Scripting (XSS). The package does not sanitize URL parameters in the testCommon.js and runner.html test files, allowing attackers to execute arbitrary JavaScript in the victim's browser. Recommendation Upgrade to version 1.4.2 or later.

    Recommended action: Upgrade to 1.13.1, 1.12.4, 1.11.6 or 1.10.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →