High, CVSS 7.7npmAmendedPublished
Potential memory exposure in dns-packet
CVE-2021-23386 · GHSA-3wcq-x3mq-6r9p
- Affected
- npm dns-packet < 1.3.2; >= 2.0.0, < 5.2.2
- Fixed in
- 5.2.21.3.2· Vendor fix available
- Issue
- This affects the package dns-packet before versions 1.3.2 and 5.2.2. It creates buffers with allocUnsafe and does not always fill them before forming network packets. This can expose internal application memory over unencrypted network when querying crafted invalid domain names.
Recommended action: Upgrade to 5.2.2 or 1.3.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.