Skip to content

← Public intelligence

npm package

diff

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.7npmAmendedPublished

    jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch

    CVE-2026-24001 · GHSA-73rr-hh4g-fpgx

    Affected
    • npm diff >= 6.0.0, < 8.0.3; >= 5.0.0, < 5.2.2; >= 4.0.0, < 4.0.4; < 3.5.1
    Fixed in
    8.0.35.2.23.5.14.0.4· Vendor fix available
    Issue
    Impact Attempting to parse a patch whose filename headers contain the line break characters \r, \u2028, or \u2029 can cause the parsePatch method to enter an infinite loop. It then consumes memory without limit until the process crashes due to running out of memory. Applications are therefore likely to be vulnerable to a denial-of-service attack if they call parsePatch with a user-provided patch as input. A large payload is not needed to trigger the vulnerability, so size limits on user input do not provide any protection. Furthermore, some applications may be vulnerable even when calling parsePatch on a patch generated by the application itself if the user is nonetheless able to control the filename headers (e.g. by directly providing the filenames of the files to be diffed). The applyPatch method is similarly affected if (and only if) called with a string representation of a patch as an argument, since under the hood it parses that string using parsePatch. Other methods of the…

    Recommended action: Upgrade to 8.0.3, 5.2.2, 4.0.4 or 3.5.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Regular Expression Denial of Service (ReDoS)

    GHSA-h6ch-v84p-w6p9

    Affected
    • npm diff < 3.5.0
    Fixed in
    3.5.0· Vendor fix available
    Issue
    A vulnerability was found in diff before v3.5.0, the affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.

    Recommended action: Upgrade to 3.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →