UnratednpmAmendedPublished
Cross-Site Scripting in diagram-js
GHSA-8fw4-xh83-3j6q
- Affected
- npm diagram-js < 2.6.2; >= 3.0.0, < 3.3.1
- Fixed in
- 3.3.12.6.2· Vendor fix available
- Issue
- Versions of diagram-js prior to 3.3.1 (for 3.x) and 2.6.2 (for 2.x) are vulnerable to Cross-Site Scripting. The package fails to escape output of user-controlled input in search-pad, allowing attackers to execute arbitrary JavaScript. Recommendation If you are using diagram-js 3.x, upgrade to version 3.3.1. If you are using diagram-js 2.x, upgrade to version 2.6.2.
Recommended action: Upgrade to 3.3.1 or 2.6.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.