Skip to content

← Public intelligence

npm package

devcert

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Regular expression denial of service in devcert

    CVE-2022-1929 · GHSA-fp36-299x-pwmw

    Affected
    • npm devcert < 1.2.1
    Fixed in
    1.2.1· Vendor fix available
    Issue
    An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the devcert npm package, when an attacker is able to supply arbitrary input to the certificateFor method

    Recommended action: Upgrade to 1.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Injection and Command Injection in devcert

    CVE-2020-8186 · GHSA-4228-7qvx-f4rq

    Affected
    • npm devcert <= 1.1.1
    Fixed in
    1.1.2· Vendor fix available
    Issue
    A command injection vulnerability in the devcert module may lead to remote code execution when users of the module pass untrusted input to the certificateFor function.

    Recommended action: Upgrade to 1.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →