High, CVSS 7.4npmAmendedPublished
degit has a Command Injection issue
CVE-2026-11572 · GHSA-77c7-pq4r-6mcq
- Affected
- npm degit < 2.8.6; >= 3.0.0, < 3.3.1
- Fixed in
- 2.8.63.3.1· Vendor fix available
- Issue
- Versions of the package degit before 2.8.6, from 3.0.0 and before 3.3.1 are vulnerable to Command Injection due to improper sanitisation of user input for git shell commands directly invoked with exec() method by cloneWithGit() and fetchRefs() functions. An attacker can execute arbitrary operating system commands as the process user by supplying a specially crafted git repository name.
Recommended action: Upgrade to 3.3.1 or 2.8.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.