UnratednpmAmendedPublished
Arbitrary File Overwrite in decompress-zip
GHSA-73v8-v6g4-vrpm
- Affected
- npm decompress-zip < 0.2.2; >= 0.3.0, < 0.3.2
- Fixed in
- 0.2.20.3.2· Vendor fix available
- Issue
- Vulnerable versions of decompress-zip are affected by the Zip-Slip vulnerability, an arbitrary file write vulnerability. The vulnerability occurs because decompress-zip does not verify that extracted files do not resolve to targets outside of the extraction root directory. Recommendation For decompress-zip 0.2.x upgrade to 0.2.2 or later. For decompress-zip 0.3.x upgrade to 0.3.2 or later.
Recommended action: Upgrade to 0.3.2 or 0.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.