High, CVSS 7.5npmAmendedPublished
Regular Expression Denial of Service in decamelize
CVE-2017-16023 · GHSA-q5c4-39f5-m68j
- Affected
- npm decamelize >= 1.1.0, <= 1.1.1
- Fixed in
- 1.1.2· Vendor fix available
- Issue
- Affected versions of decamelize are susceptible to a denial of service vulnerability when user input is passed directly into decamelize. Recommendation Update to version 1.1.2 or later.
Recommended action: Upgrade to 1.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.