Critical, CVSS 9.8npmAmendedPublished
OS Command Injection in curling
CVE-2019-10789 · GHSA-xmxh-g7wj-8m4m
- Affected
- npm curling <= 1.0.0
- Fixed in
- 1.1.0· Vendor fix available
- Issue
- npm package curling before version 1.1.0 is vulnerable to Command Injection via the run function. The command argument can be controlled by users without any sanitization.
Recommended action: Upgrade to 1.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.