Skip to content

← Public intelligence

npm package

css-what

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    css-what vulnerable to ReDoS due to use of insecure regular expression

    CVE-2022-21222 · GHSA-p28h-cc7q-c4fg

    Affected
    • npm css-what < 2.1.3
    Fixed in
    2.1.3· Vendor fix available
    Issue
    The package css-what before 2.1.3 is vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of insecure regular expression in the reattr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

    Recommended action: Upgrade to 2.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    Denial of service in css-what

    CVE-2021-33587 · GHSA-q8pj-2vqx-8ggc

    Affected
    • npm css-what >= 4.0.0, <= 5.0.0
    Fixed in
    5.0.1· Vendor fix available
    Issue
    The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size of the input.

    Recommended action: Upgrade to 5.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →