Critical, CVSS 9.8npmAmendedPublished
Insufficient Entropy in cryptiles
CVE-2018-1000620 · GHSA-rq8g-5pc5-wrhr
- Affected
- npm cryptiles >= 4.0.0, < 4.1.2; >= 3.1.0, < 3.1.3
- Fixed in
- 4.1.23.1.3· Vendor fix available
- Issue
- Versions of cryptiles prior to 4.1.2 are vulnerable to Insufficient Entropy. The randomDigits() method does not provide sufficient entropy and its generates digits that are not evenly distributed. Recommendation Upgrade to version 4.1.2. The package is deprecated and has been moved to @hapi/cryptiles and it is strongly recommended to use the maintained package.
Recommended action: Upgrade to 4.1.2 or 3.1.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.