Skip to content

← Public intelligence

npm package

cruddl

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.9npmAmendedPublished

    cruddl vulnerable to ArangoDB Query Language (AQL) injection through flexSearch

    CVE-2022-36084 · GHSA-qm4w-4995-vg7f

    Affected
    • npm cruddl >= 3.0.0, < 3.0.2; >= 1.1.0, < 2.7.0
    Fixed in
    3.0.22.7.0· Vendor fix available
    Issue
    Impact If a vunerable version of cruddl is used to generate a schema that uses @flexSearchFulltext, users of that schema may be able to inject arbitrary AQL queries that will be forwarded to and executed by ArangoDB. Schemas that do not use @flexSearchFulltext are not affected. The attacker needs to have READ permission to at least one root entity type that has @flexSearchFulltext enabled. Patches The issue has been fixed in version 3.0.2 and in version 2.7.0 of cruddl. Workarounds Users can temporarily remove @flexSearchFulltext from their schemas before they can update cruddl. For more information If you have any questions or comments about this advisory: Open an issue in cruddl Email us at security@aeb.com

    Recommended action: Upgrade to 3.0.2 or 2.7.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →