Skip to content

← Public intelligence

npm package

crud-file-server

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Path Traversal in crud-file-server

    CVE-2018-3733 · GHSA-vfp9-gwrh-wq9g

    Affected
    • npm crud-file-server < 0.9.0
    Fixed in
    0.9.0· Vendor fix available
    Issue
    Versions of crud-file-server prior to 0.9.0 are vulnerable to Path Traversal. The package fails to sanitize URLs, allowing attackers to access server files outside of the served folder using relative paths. Recommendation Upgrade to version 0.9.0 or later.

    Recommended action: Upgrade to 0.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1npmAmendedPublished

    Cross-site Scripting (XSS) - Stored in crud-file-server

    CVE-2018-3726 · GHSA-h24f-9mm4-w336

    Affected
    • npm crud-file-server <= 0.7.0
    Fixed in
    0.8.0· Vendor fix available
    Issue
    Versions of crud-file-server before 0.8.0 are vulnerable to stored cross-site scripting (XSS). This is due to insufficient santiziation of filenames when directory index is served by crud-file-server. Recommendation Update to version 0.8.0 or later.

    Recommended action: Upgrade to 0.8.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →