Medium, CVSS 6.1npmAmendedPublished
Critters Cross-site Scripting Vulnerability
CVE-2023-3481 · GHSA-cx3j-qqxj-9597
- Affected
- npm critters >= 0.0.17, <= 0.0.19
- Fixed in
- 0.0.20· Vendor fix available
- Issue
- Impact Critters version 0.0.17-0.0.19 have an issue when parsing the HTML which leads to a potential cross-site scripting (XSS) bug. Patches The bug has been fixed in v0.0.20. Workarounds Upgrading Critters version to 0.0.20 is the easiest fix. This is a non breaking version upgrade so we recommend all users to use v0.0.20.
Recommended action: Upgrade to 0.0.20 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.