Skip to content

← Public intelligence

npm package

converse.js

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    Converse.js Exposure of Sensitive Information

    CVE-2018-6591 · GHSA-mv4h-qm24-x4gh

    Affected
    • npm converse.js < 3.3.3
    Fixed in
    3.3.3· Vendor fix available
    Issue
    Converse.js and Inverse.js through 3.3 allow remote attackers to obtain sensitive information because it is too difficult to determine whether safe publication of private data was configured or even intended. For example, users might have an expectation that chatroom bookmarks are private, but the various interacting software components do not necessarily make that happen.

    Recommended action: Upgrade to 3.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.9npmAmendedPublished

    User Impersonation in converse.js

    CVE-2017-5858 · GHSA-w973-2qcc-p78x

    Affected
    • npm converse.js < 1.0.7; >= 2.0.0, < 2.0.5
    Fixed in
    2.0.51.0.7· Vendor fix available
    Issue
    Versions of converse.js prior to 1.0.7 for 1.x or 2.0.5 for 2.x are vulnerable to User Impersonation. The package provides an incorrect implementation of XEP-0280: Message Carbons that allows a remote attacker to impersonate any user, including contacts, in the vulnerable application's display. This allows for various kinds of social engineering attacks. Recommendation If you're using converse.js 1.x, upgrade to 1.0.7 or later. If you're using converse.js 2.x, upgrade to 2.0.5 or later.

    Recommended action: Upgrade to 2.0.5 or 1.0.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →