High, CVSS 7.5npmAmendedPublished
Regular Expression Denial of Service in content
CVE-2017-16111 · GHSA-x6wp-rfwh-hcx7
- Affected
- npm content < 3.0.7
- Fixed in
- 3.0.7· Vendor fix available
- Issue
- Affected versions of content are vulnerable to a regular expression denial of service when parsing malicious Content-Type and Content-Disposition headers. Recommendation Update to version 3.0.6 or later.
Recommended action: Upgrade to 3.0.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.