UnratednpmAmendedPublished
Memory Exposure in concat-stream
GHSA-g74r-ffvr-5q9f
- Affected
- npm concat-stream >= 1.5.0, < 1.5.2; >= 1.4.0, < 1.4.11; >= 1.3.0, < 1.3.2
- Fixed in
- 1.5.21.3.21.4.11· Vendor fix available
- Issue
- Versions of concat-stream before 1.5.2 are vulnerable to memory exposure if userp provided input is passed into write() Versions <1.3.0 are not affected due to not using unguarded Buffer constructor. Recommendation Update to version 1.5.2, 1.4.11, 1.3.2 or later. If you are unable to update make sure user provided input into the write() function is not a number.
Recommended action: Upgrade to 1.5.2, 1.4.11 or 1.3.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.