High, CVSS 8.1npmAmendedPublished
Clamscan vulnerable to command injection
CVE-2020-7613 · GHSA-5v25-xr56-phph
- Affected
- npm clamscan <= 1.2.0
- Fixed in
- 1.3.0· Vendor fix available
- Issue
- clamscan through 1.2.0 is vulnerable to Command Injection. It is possible to inject arbitrary commands as part of the isclamavbinary function located within Index.js. It should be noted that this vulnerability requires a pre-requisite that a folder should be created with the same command that will be chained to execute. This lowers the risk of this issue.
Recommended action: Upgrade to 1.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.