Skip to content

← Public intelligence

npm package

canvas

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8npmAmendedPublished

    Buffer overflow in canvas

    CVE-2020-8215 · GHSA-73rg-x683-m3qw

    Affected
    • npm canvas < 1.6.11
    Fixed in
    1.6.11· Vendor fix available
    Issue
    A buffer overflow is present in canvas versions before 1.6.11, which could lead to a Denial of Service or execution of arbitrary code when it processes a user-provided image.

    Recommended action: Upgrade to 1.6.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Denial of Service in canvas

    GHSA-vpq5-4rc8-c222

    Affected
    • npm canvas < 1.6.10
    Fixed in
    1.6.10· Vendor fix available
    Issue
    Versions of canvas prior to 1.6.10 are vulnerable to Denial of Service. Processing malicious JPEGs or GIFs could crash the node process. Recommendation Upgrade to version 1.6.10

    Recommended action: Upgrade to 1.6.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →