Medium, CVSS 6.6npmAmendedPublished
BrowserStack Local vulnerable to Command Injection through logfile variable
CVE-2025-57283 · GHSA-g4w6-c99w-4wh7
- Affected
- npm browserstack-local <= 1.5.8
- Fixed in
- 1.5.9· Vendor fix available
- Issue
- The Node.js package browserstack-local 1.5.8 contains a command injection vulnerability. This occurs because the logfile variable is not properly sanitized in lib/Local.js.
Recommended action: Upgrade to 1.5.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.