Skip to content

← Public intelligence

npm package

blamer

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5npmAmendedPublished

    blamer vulnerable to Arbitrary Argument Injection via the blameByFile() API

    CVE-2023-26143 · GHSA-6f9p-g466-f8v8

    Affected
    • npm blamer < 1.0.4
    Fixed in
    1.0.4· Vendor fix available
    Issue
    Versions of the blamer package before 1.0.4 are vulnerable to Arbitrary Argument Injection via the blameByFile() API. The library does not sanitize for user input or validate the given file path conforms to a specific schema, nor does it properly pass command-line flags to the git binary using the double-dash POSIX characters (--) to communicate the end of options.

    Recommended action: Upgrade to 1.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    Improper Neutralization of Special Elements used in an OS Command in Blamer

    CVE-2019-10807 · GHSA-8cxp-cjm8-fj36

    Affected
    • npm blamer < 1.0.1
    Fixed in
    1.0.1· Vendor fix available
    Issue
    Blamer versions prior to 1.0.1 allows execution of arbitrary commands. It is possible to inject arbitrary commands as part of the arguments provided to blamer.

    Recommended action: Upgrade to 1.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.8npmAmendedPublished

    Code injection in blamer

    CVE-2020-8137 · GHSA-7vm7-j8p7-h346

    Affected
    • npm blamer <= 1.0.0
    Fixed in
    1.0.1· Vendor fix available
    Issue
    Code injection vulnerability in blamer 1.0.0 and earlier may result in remote code execution when the input can be controlled by an attacker.

    Recommended action: Upgrade to 1.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →