Skip to content

← Public intelligence

npm package

backbone

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4npmAmendedPublished

    Cross-Site Scripting in backbone

    CVE-2016-10537 · GHSA-j6p2-cx3w-6jcp

    Affected
    • npm backbone >= 0.3.3, < 0.5.0
    Fixed in
    0.5.0· Vendor fix available
    Issue
    Affected versions of backbone are vulnerable to cross-site scripting when users are allowed to supply input to the Model#Escape function, and the output is then written to the DOM. The vulnerability occurs as a result of the regular expression used to encode metacharacters failing to take HTML Entities such as &#60; into account. Recommendation Update to version 0.5.0 or later.

    Recommended action: Upgrade to 0.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →