Skip to content

← Public intelligence

npm package

axios

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

55 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    Server-Side Request Forgery in axios

    CVE-2024-39338 · GHSA-8hc4-vh64-cxmj

    Affected
    • npm axios >= 1.3.2, <= 1.7.3
    Fixed in
    1.7.4· Vendor fix available
    Issue
    axios 1.7.2 allows SSRF via unexpected behavior where requests for path relative URLs get processed as protocol relative URLs.

    Recommended action: Upgrade to 1.7.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.5npmAmendedPublished

    Axios Cross-Site Request Forgery Vulnerability

    CVE-2023-45857 · GHSA-wf5p-g6vw-rhxx

    Affected
    • npm axios >= 1.0.0, < 1.6.0; >= 0.8.1, < 0.28.0
    Fixed in
    0.28.01.6.0· Vendor fix available
    Issue
    An issue discovered in Axios 0.8.1 through 1.5.1 inadvertently reveals the confidential XSRF-TOKEN stored in cookies by including it in the HTTP header X-XSRF-TOKEN for every request made to any host allowing attackers to view sensitive information.

    Recommended action: Upgrade to 1.6.0 or 0.28.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5npmAmendedPublished

    axios Inefficient Regular Expression Complexity vulnerability

    CVE-2021-3749 · GHSA-cph5-m8f7-6c5x

    Affected
    • npm axios < 0.21.2
    Fixed in
    0.21.2· Vendor fix available
    Issue
    axios before v0.21.2 is vulnerable to Inefficient Regular Expression Complexity.

    Recommended action: Upgrade to 0.21.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 5.9npmAmendedPublished

    Axios vulnerable to Server-Side Request Forgery

    CVE-2020-28168 · GHSA-4w2v-q235-vp99

    Affected
    • npm axios < 0.21.1
    Fixed in
    0.21.1· Vendor fix available
    Issue
    Axios NPM package 0.21.0 contains a Server-Side Request Forgery (SSRF) vulnerability where an attacker is able to bypass a proxy by providing a URL that responds with a redirect to a restricted host or IP address.

    Recommended action: Upgrade to 0.21.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. High, CVSS 7.5npmAmendedPublished

    Denial of Service in axios

    CVE-2019-10742 · GHSA-42xw-2xvc-qx8m

    Affected
    • npm axios <= 0.18.0
    Fixed in
    0.18.1· Vendor fix available
    Issue
    Versions of axios prior to 0.18.1 are vulnerable to Denial of Service. If a request exceeds the maxContentLength property, the package prints an error but does not stop the request. This may cause high CPU usage and lead to Denial of Service. Recommendation Upgrade to 0.18.1 or later.

    Recommended action: Upgrade to 0.18.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →