Critical, CVSS 9.8npmAmendedPublished
Malicious Package in another-date-picker
GHSA-2p62-c4rm-mr72
- Affected
- npm another-date-picker >= 2.0.43, <= 2.0.43
- Fixed in
- 2.0.45· Vendor fix available
- Issue
- Version 2.0.43 of another-date-picker contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl= Recommendation If version 2.0.43 of this module is found installed you will want to replace it with a version before or after 2.0.43. In addition to replacing the installed module, you will also want to evaluate your application to determine whether or not user data was compromised.
Recommended action: Upgrade to 2.0.45 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.