Skip to content

← Public intelligence

npm package

acorn

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Regular Expression Denial of Service in Acorn

    GHSA-6chw-6frg-f759

    Affected
    • npm acorn >= 6.0.0, < 6.4.1; >= 7.0.0, < 7.1.1; >= 5.5.0, < 5.7.4
    Fixed in
    6.4.17.1.15.7.4· Vendor fix available
    Issue
    Affected versions of acorn are vulnerable to Regular Expression Denial of Service. A regex in the form of /[x-\ud800]/u causes the parser to enter an infinite loop. The string is not valid UTF16 which usually results in it being sanitized before reaching the parser. If an application processes untrusted input and passes it directly to acorn, attackers may leverage the vulnerability leading to Denial of Service.

    Recommended action: Upgrade to 7.1.1, 6.4.1 or 5.7.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →