Skip to content

← Public intelligence

npm package

@tanstack/react-query-next-experimental

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2npmAmendedPublished

    react-query-streamed-hydration Cross-site Scripting vulnerability

    CVE-2024-24558 · GHSA-997g-27x8-43rf

    Affected
    • npm @tanstack/react-query-next-experimental >= 5.0.0, < 5.18.0
    Fixed in
    5.18.0· Vendor fix available
    Issue
    Impact The @tanstack/react-query-next-experimental NPM package is vulnerable to a cross-site scripting vulnerability. To exploit this, an attacker would need to either inject malicious input or arrange to have malicious input be returned from an endpoint. This vulnerability arises from improper handling of untrusted input when @tanstack/react-query-next-experimental performs server-side rendering of HTML pages. To fix this vulnerability, we implemented appropriate escaping to prevent javascript injection into rendered pages. Patches To fix this issue, please update to version 5.18.0 or later. Workarounds There are no known workarounds for this issue. Please update to version 5.18.0 or later.

    Recommended action: Upgrade to 5.18.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →