Critical, CVSS 9.3npmAmendedPublished
Strapi Vulnerable to SQL Injection in Content Type Builder
CVE-2026-22599 · GHSA-3xcq-8mjw-h6mx
- Affected
- npm @strapi/content-type-builder >= 5.0.0, < 5.33.2
- Fixed in
- 5.33.2· Vendor fix available
- Issue
- of CVE-2026-22599 Vulnerability Details - CVE: CVE-2026-22599 - CVSS v3.1 Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N (9.3 — Critical) - Affected Versions: @strapi/content-type-builder <=5.33.1 (v5), @strapi/plugin-content-type-builder <=4.26.0 (v4) - How to Patch: Immediately update your Strapi to =5.33.2 (v5) or =4.26.1 (v4) Description of CVE-2026-22599 A database-query injection vulnerability existed in the Strapi Content-Type Builder write API. An authenticated administrator could inject arbitrary database statements through the column.defaultTo attribute when creating or modifying a content type. Setting defaultTo as a tuple [value, { isRaw: true }] caused the value to be passed directly into Knex's db.connection.raw() during schema migration without sanitization, allowing arbitrary statement execution at the database layer. Depending on the database engine, this enabled arbitrary file read via database utility functions, denial of service…
Recommended action: Upgrade to 5.33.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.