Skip to content

← Public intelligence

npm package

@shopify/koa-shopify-auth

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Cross-site scripting in @shopify/koa-shopify-auth

    CVE-2020-8176 · GHSA-jqh7-w5pr-cr56

    Affected
    • npm @shopify/koa-shopify-auth >= 3.1.61, <= 3.1.62
    Fixed in
    3.1.63· Vendor fix available
    Issue
    A cross-site scripting vulnerability exists in koa-shopify-auth v3.1.61-v3.1.62 that allows an attacker to inject JS payloads into the shop parameter on the /shopify/auth/enablecookies endpoint.

    Recommended action: Upgrade to 3.1.63 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →