Skip to content

← Public intelligence

npm package

@shopify/hydrogen

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3npmAmendedPublished

    Potential Cross-site Scripting vulnerability in Hydrogen

    CVE-2022-29230 · GHSA-6j22-wv8g-894f

    Affected
    • npm @shopify/hydrogen >= 0.10.0, < 0.19.0
    Fixed in
    0.19.0· Vendor fix available
    Issue
    Impact There is a potential Cross-Site Scripting (XSS) vulnerability where an arbitrary user is able to execute scripts on pages that are built with Hydrogen. This affects all versions of Hydrogen starting from version 0.10.0 to 0.18.0. This vulnerability is exploitable in applications whose hydrating data is user controlled. Patches All Hydrogen users should upgrade their project to v0.19.0. Workarounds There is no current workaround, and users should update as soon as possible. Additionally, the Content Security Policy is not an effective mitigation for this vulnerability. References GitHub: Hydrogen v0.19.0 Fix PR: https://github.com/Shopify/hydrogen/pull/1272 For more information If you have any questions or comments about this advisory: Open an issue in Shopify/hydrogen

    Recommended action: Upgrade to 0.19.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →