Critical, CVSS 9.4npmAmendedPublished
@sap/cds-mtx: Credential disclosure in multitenant applications using SAP Cloud Application Programming Model (CAP)
CVE-2026-76969 · GHSA-955m-rr6m-2f9v
- Affected
- npm @sap/cds-mtxs >= 4.0.1, < 4.0.3; >= 3.0.1, < 3.9.7; >= 2.0.2, < 2.7.7; < 1.18.4
- Fixed in
- 2.7.73.9.74.0.31.18.4· Vendor fix available
- Issue
- @sap/cds-mtxs NPM library does not perform sufficient checks on certain functionality used in multitenant CAP applications with extensibility enabled. An unauthenticated attacker could send specially crafted requests to obtain sensitive credentials and abuse them to replace or delete tenant data. Successful exploitation can result in a high impact on availability and integrity of the application. There may also be partial impact to the confidentiality of business data.
Recommended action: Upgrade to 4.0.3, 3.9.7, 2.7.7 or 1.18.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.