Skip to content

← Public intelligence

npm package

@rocket.chat/message-parser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9npmAmendedPublished

    Denial of service in rocket chat message parser

    CVE-2024-46935 · GHSA-6375-pg5j-8wph

    Affected
    • npm @rocket.chat/message-parser < 0.31.30
    Fixed in
    0.31.30· Vendor fix available
    Issue
    Rocket.Chat 6.12.0, 6.11.2, 6.10.5, 6.9.6, 6.8.6, 6.7.8, and earlier is vulnerable to denial of service (DoS). Attackers who craft messages with specific characters may crash the workspace due to an issue in the message parser.

    Recommended action: Upgrade to 0.31.30 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →